TLS 1.2 PCI Compliance

Important Security and Compliance Reminder
TLS ends June 26, 2018, at 12 AM EST

As a reminder, Paya will be disabling TLS 1.0 security protocols on June 26, 2018, at 12:00 am EST. You should have received several communications to date regarding the TLS upgrade and some of them may have been confusing. It is important to know that Paya will continue to support TLS 1.1 and 1.2 communication protocols.

Please note, Paya’s legacy API’s are still supported and will continue to be supported after TLS 1.0 has been disabled.

Below are the steps you need to take in order to continue with your credit card processing services and to ensure no disruption occurs.

  • If you have already upgraded to TLS 1.1 or 1.2 and/or SED 2.0 you don’t need to do anything else and you WILL NOT experience a service interruption.
  • If you have not upgraded, you will need to take action immediately (prior to June 26, 2018). Please click here for further product information.

For further detailed information about the transition for TLS 1.2, please review this article from the PCI SSC.

For Guideline on selection, configuration and use of TLS implementations, please review this help document from National Institute of Standards and Technology.

We will continue to update this page with communications regarding updates and solutions. As always, Paya is here to support our customers. If you need additional information about TLS compliance and your software, click here. Should you need further assistance please contact customer support at 800-261-0240.